What errors are you seei…

2 minute read

What errors are you seeing?


Its like the longest stack trace I have ever seen in a ts error :slightly_smiling_face:

Are your @nrwl/workspace and @nrwl/nx-plugin the same version in your package.json?

yes, both 8.12.10

How about in the package-lock or yarn.lock?

I only seen that error when there’s a version mismatch somewhere

the workpsace was not create with create-nx-plugin but was an existing angular workspace turned nx workspace


Do you have angular-devkit/schematics in your package.json?

yes, @angular-devkit/schematics 8.3.20

package-lock is fine regarding nx pacakges… both 8.12.0

actually I don’t have it in my package.json, but this is the version that is installed according to ng –version

just for the sake of making sure, let me reinstall node_modules

If that doesn’t work, can you install: "@angular-devkit/schematics@8.3.23"

yes, will get back to you shortly

thanks for the support :+1:

hm, so I removed node_modules and also the package-lock. now, @angular-devkit/schematics@8.3.25 is installed, but still same error

Hmmm there’s probably a version mismatch somewhere

Can you make a issue on Nrwl/nx with a repro? I’ll have to take a look on a computer

I am trying to reproduce it in a minimal repo

Thank you

hm, so if i create a new workspace with npx create-nx-plugin@8 my-org --pluginName my-plugin everything works fine, so yes, it must be some dependecy mismatch

thanks for your help

You can see in the error message that Nrwl/workspace is using its own version of schematics because has its own node_modules folder

Compared to the one that’s being used for your project which is in the root node_modules

yes I noticed that

it has 8.3.23 installed

interesting, I specifically now installed @angular-devkit/core and schematics 8.3.23 in my project, now it works

Yea I suspected that. I think we might have to loosen the dependency version on some packages

hm, but what is the problem exactly? that my project didn’t have exact 8.3.23 - or that my project was different from workspace dependency? I guess the 2nd one?

so if workspace had 8.3.24, my project would also need 8.3.24?

Probably the version of angular cli used a higher version of schematics

And yes

I’m guessing the angular cli was updated recently and updated its deps

The Nrwl packages have the version hardcoded

Well, pinned

basically we need to make sure, that the nrwl workspace does not install its own schematic dependency, right?

Yea it should use whatever is there already. As soon as npm or yarn sees a difference it’ll install packages differently, right

So we’ll just have to make sure the Nrwl packages have a dep of > 802.x < 900

Or whatever the version is, I don’t remember :sweat_smile:

Basically greater than 8 less than 9

yes it has "dependencies": { "@angular-devkit/core": "8.3.23", "@angular-devkit/schematics": "8.3.23",


pinned to that version

Uh huh

Can you make a issue and I’ll fix it next week?


Thank you!

Steps to reproduce is probably create workspace, and only update the angular cli dep

To the latest version 8

hm while I am typing the issue… is it actually a problem for the workspace package or the nx-plugin package? or both? both have fixed deps to 8.3.23

Workspace and all

ok I submitted https://github.com/nrwl/nx/issues/2661 thanks for helping me investigate… I made my ticket around v8, I don’t know if the same thing applies to v9 also