Hi all I migrated our a…

1 minute read

Hi all, I migrated our angular-nest app from version 8.6.0 to 9.1.2 and now when I’m attaching a debugger to the process of the nest app, the breakpoints are not working. So I tried creating a new workspace using the angular-nest preset and the it’s the same. Someone encountered that also?

(The sourcemaps exists in the dist folder and the paths inside looks fine)

Edit: I opened an issue https://github.com/nrwl/nx/issues/2690


Check your angular.json/tsconfig/nx.json see if they changed after migrate

Is that vscode? If so reload the window I find typescript doesn’t always update correctly for me

Thanks for the reply! I tried reopening vscode a few times and nothing changed. angular.json - only passWithNoTests and aot: true been added Nothing changed in nx.json and tsconfig files.

hmm thats odd try deleting your dist folder and rebuilding?

Already did :slightly_smiling_face:

it seems like vscode isnt reading the correct files

Tried also removing node_modules and reinstalling


It’s not working also with the Chrome nodejs debugger

are you webpacking?


latest version of vscode?



None of them related to my issue. In vscode I just try to attach without any configurations and in chrome I try to use the from the icon in the devtools.

Both of them works fine with my repo before the upgrade

hmm something changed question is what lol

:joy: after a lot of research, my best guess is that there’s a bug in one of the packages

Should I open an issue?

could it be a result of the postinstall of the ngcc?

anything is possible, create a min repo and open an issue

ok, thanks!

np wish i could of been more help :smile:

so while I was working on a very descriptive issue, I tried adding a port to the options and now it works. but I guess that it should work also with the default port 0 (https://github.com/nrwl/nx/pull/2510) Am I right?

yeah it should work with default settings

maybe comment on that PR and say its still an issue?

I haven’t submitted it yet :laughing:

i mean the one you links, submit your and comment on the above one

well, I’ve figured out that the problem isn’t with the breakpoints. I was trying to attach to a different process before that. this is the real issue