Is they a way to run nr…

1 minute read

Is they a way to run @nrwl/workspace but go to the @next version


What do you mean, you want to install the 9.x version of the workspace?

Yea, didn’t realise it was using angular ng update still. Thought this would have been migrated. added –next solved the issue

yes but try – –next

this way it is passed trough to the ng update

Yea :slightly_smiling_face: I was just being stupid. Got it working. So many breaking changes in new angular. There a bloody joke.

I do not think it is fair to call the Angular team a joke because of the v9 release. Yes there are some breaking changes and some them have been known for a long time (deprecations in prior versions) which we have all had ample time to prepare for. They have tried their best to minimize the impact on us by providing migrations via the CLI and I think they did an awesome job, we migrated our relatively large monorepo to v9 last night with little to no issue by following the update guide. I know a lot of people are upset that it took so long to release but I for one would much rather waiting than for them to release a half-baked version riddled with bugs and other issues that even more people complained about.

You are obviously welcome to your own opinion but the Angular team did something amazing with v9 and I think we should respect that. Software development isn’t perfect, it is hard to create something out of nothing and even harder to manage not breaking everyone’s somethings.

Don’t get me wrong I love what their done. I love the CLI their built, it’s a shame they don’t break it away from “angular”. I would love to see @angular-devkit renamed. But they do love breaking changes. It might be because I’m migrating a AngularJS applications again for clients. When its just a core angular project at the core it’s been great